re = /^[+-]?([0-9]{1,3}(,[0-9]{3})*(\.[0-9]+)?|\d*\.\d+|\d+)$/m
str = '123,344.456
1234556
123456.124
-1234
-123,456,789
+1234.67
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end