using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\[99m([^:]+).*?\[88m([^[]+)";
string input = @"'[12m[99mSOME STRING 1: [bla[bla[88mSOMETHING 2[00m['
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}