// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\[99m([^:]+).*?\[88m([^[]+)").unwrap();
let string = "'[12m[99mSOME STRING 1: [bla[bla[88mSOMETHING 2[00m['
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}