const regex = /\[99m([^:]+).*?\[88m([^[]+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\[99m([^:]+).*?\\[88m([^[]+)', 'gm')
const str = `'[12m[99mSOME STRING 1: [bla[bla[88mSOMETHING 2[00m['
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}