$re = '/\[99m([^:]+).*?\[88m([^[]+)/m';
$str = '\'[12m[99mSOME STRING 1: [bla[bla[88mSOMETHING 2[00m[\'
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);