package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\[99m([^:]+).*?\[88m([^[]+)`)
var str = `'[12m[99mSOME STRING 1: [bla[bla[88mSOMETHING 2[00m['
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}