#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "^d.+\d{3}$"
Local $sString = "Advertised to update-groups:" & @CRLF & _
" 14 "
Local $sSubst = "\1 "
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)