// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"^d.+\d{3}$").unwrap();
let string = "Advertised to update-groups:
14 ";
let substitution = "\\1 ";
// result will be a String with the substituted value
let result = regex.replace(string, substitution);
println!("{}", result);
}