const regex = new RegExp('^d.+\\d{3}$', '')
const str = `Advertised to update-groups:
14 `;
const subst = `\1 `;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);