import re
regex = re.compile(r"^d.+\d{3}$")
test_str = ("Advertised to update-groups:\n"
" 14 ")
subst = "\\1 "
result = regex.sub(subst, test_str, count=1)
if result:
print(result)