$re = '/^d.+\d{3}$/';
$str = 'Advertised to update-groups:
14 ';
$subst = "\1 ";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;