#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "\[img]([^'\"&?]*?/([^'\"&?/]*\.(?:gif|jpe?g|png|bmp)))\[\/img]"
Local $sString = "style_Forever 21 [img]http://cdn9.lbstatic.nu/files/looks/medium/2013/08/15/3225332_IMG_20130810_2.jpg[/img][img]http://cdn11.lbstatic.nu/files/looks/medium/2013/08/15/3225294_1000340_10201946229836897_118758683_n.jpg[/img]"
Local $sSubst = "<img src="$1" alt="$2"/>"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)