import Foundation
let pattern = #"\[img]([^'\"&?]*?/([^'\"&?/]*\.(?:gif|jpe?g|png|bmp)))\[\/img]"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"style_Forever 21 [img]http://cdn9.lbstatic.nu/files/looks/medium/2013/08/15/3225332_IMG_20130810_2.jpg[/img][img]http://cdn11.lbstatic.nu/files/looks/medium/2013/08/15/3225294_1000340_10201946229836897_118758683_n.jpg[/img]"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"<img src="$1" alt="$2"/>"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)