package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\[img]([^'\"&?]*?/([^'\"&?/]*\.(?:gif|jpe?g|png|bmp)))\[\/img]`)
var str = `style_Forever 21 [img]http://cdn9.lbstatic.nu/files/looks/medium/2013/08/15/3225332_IMG_20130810_2.jpg[/img][img]http://cdn11.lbstatic.nu/files/looks/medium/2013/08/15/3225294_1000340_10201946229836897_118758683_n.jpg[/img]`
var substitution = "<img src="$1" alt="$2"/>"
fmt.Println(re.ReplaceAllString(str, substitution))
}