const regex = new RegExp('\\[img]([^\\'\\"&?]*?/([^\\'\\"&?/]*\\.(?:gif|jpe?g|png|bmp)))\\[\\/img]', 'g')
const str = `style_Forever 21 [img]http://cdn9.lbstatic.nu/files/looks/medium/2013/08/15/3225332_IMG_20130810_2.jpg[/img][img]http://cdn11.lbstatic.nu/files/looks/medium/2013/08/15/3225294_1000340_10201946229836897_118758683_n.jpg[/img]`;
const subst = `<img src="$1" alt="$2"/>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);