# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\[img]([^'\"&?]*?/([^'\"&?/]*\.(?:gif|jpe?g|png|bmp)))\[\/img]"
test_str = "style_Forever 21 [img]http://cdn9.lbstatic.nu/files/looks/medium/2013/08/15/3225332_IMG_20130810_2.jpg[/img][img]http://cdn11.lbstatic.nu/files/looks/medium/2013/08/15/3225294_1000340_10201946229836897_118758683_n.jpg[/img]"
subst = "<img src=\"$1\" alt=\"$2\"/>"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.