const regex = new RegExp('(\\b(?:\\d+\\s+){2,}).*\\1', 'gm')
const str = `230 205 900 617 821 188 617 821 205 900
111 0 3 1 111 0 3 1 111 0 3 1
11 34 132 54 90 430 657 689 34 90 90 90 46 34 657 689 34 90 90 90 46 34 657 689 34 90 90 90 46 34
569 374 879 374 879 460 568 488 460 568 488 460 568 488 750 750 `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}