# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(\b(?:\d+\s+){2,}).*\1"
test_str = ("230 205 900 617 821 188 617 821 205 900 \n"
"111 0 3 1 111 0 3 1 111 0 3 1 \n"
"11 34 132 54 90 430 657 689 34 90 90 90 46 34 657 689 34 90 90 90 46 34 657 689 34 90 90 90 46 34 \n"
"569 374 879 374 879 460 568 488 460 568 488 460 568 488 750 750 ")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.