use strict;
my $str = '230 205 900 617 821 188 617 821 205 900
111 0 3 1 111 0 3 1 111 0 3 1
11 34 132 54 90 430 657 689 34 90 90 90 46 34 657 689 34 90 90 90 46 34 657 689 34 90 90 90 46 34
569 374 879 374 879 460 568 488 460 568 488 460 568 488 750 750 ';
my $regex = qr/(\b(?:\d+\s+){2,}).*\1/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}