re = /(\b(?:\d+\s+){2,}).*\1/m
str = '230 205 900 617 821 188 617 821 205 900
111 0 3 1 111 0 3 1 111 0 3 1
11 34 132 54 90 430 657 689 34 90 90 90 46 34 657 689 34 90 90 90 46 34 657 689 34 90 90 90 46 34
569 374 879 374 879 460 568 488 460 568 488 460 568 488 750 750 '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end