#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)curl.+(\d).+\s*.+(\d{4}-\d{2}.+)\",\s*\".+\"\s*\:\s*\"([a-zA-z]*)\","
Local $sString = "curl -XPUT 'http://localhost:9200/test8/test/2' -d '{" & @CRLF & _
" "date" : "2015-08-23T14:02:30"," & @CRLF & _
" "action" : "stop"," & @CRLF & _
" "myid" : 1" & @CRLF & _
"}'" & @CRLF & _
"curl -XPUT 'http://localhost:9200/test8/test/3' -d '{" & @CRLF & _
" "date" : "2015-08-23T00:01:45"," & @CRLF & _
" "action" : "start"," & @CRLF & _
" "myid" : 2" & @CRLF & _
"}'" & @CRLF & _
"curl -XPUT 'http://localhost:9200/test8/test/4' -d '{" & @CRLF & _
" "date" : "2015-08-23T00:01:55"," & @CRLF & _
" "action" : "start"," & @CRLF & _
" "myid" : 3" & @CRLF & _
"}'" & @CRLF & _
"curl -XPUT 'http://localhost:9200/test8/test/5' -d '{" & @CRLF & _
" "date" : "2015-08-23T14:04:00"," & @CRLF & _
" "action" : "stop"," & @CRLF & _
" "myid" : 2" & @CRLF & _
"}'" & @CRLF & _
"curl -XPUT 'http://localhost:9200/test8/test/6' -d '{" & @CRLF & _
" "date" : "2015-08-23T14:02:55"," & @CRLF & _
" "action" : "stop"," & @CRLF & _
" "myid" : 3" & @CRLF & _
"}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")