# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"curl.+(\d).+\s*.+(\d{4}-\d{2}.+)\",\s*\".+\"\s*\:\s*\"([a-zA-z]*)\","
test_str = ("curl -XPUT 'http://localhost:9200/test8/test/2' -d '{\n"
" \"date\" : \"2015-08-23T14:02:30\",\n"
" \"action\" : \"stop\",\n"
" \"myid\" : 1\n"
"}'\n"
"curl -XPUT 'http://localhost:9200/test8/test/3' -d '{\n"
" \"date\" : \"2015-08-23T00:01:45\",\n"
" \"action\" : \"start\",\n"
" \"myid\" : 2\n"
"}'\n"
"curl -XPUT 'http://localhost:9200/test8/test/4' -d '{\n"
" \"date\" : \"2015-08-23T00:01:55\",\n"
" \"action\" : \"start\",\n"
" \"myid\" : 3\n"
"}'\n"
"curl -XPUT 'http://localhost:9200/test8/test/5' -d '{\n"
" \"date\" : \"2015-08-23T14:04:00\",\n"
" \"action\" : \"stop\",\n"
" \"myid\" : 2\n"
"}'\n"
"curl -XPUT 'http://localhost:9200/test8/test/6' -d '{\n"
" \"date\" : \"2015-08-23T14:02:55\",\n"
" \"action\" : \"stop\",\n"
" \"myid\" : 3\n"
"}")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.