import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "curl.+(\\d).+\\s*.+(\\d{4}-\\d{2}.+)\\\",\\s*\\\".+\\\"\\s*\\:\\s*\\\"([a-zA-z]*)\\\",";
final String string = "curl -XPUT 'http://localhost:9200/test8/test/2' -d '{\n"
+ " \"date\" : \"2015-08-23T14:02:30\",\n"
+ " \"action\" : \"stop\",\n"
+ " \"myid\" : 1\n"
+ "}'\n"
+ "curl -XPUT 'http://localhost:9200/test8/test/3' -d '{\n"
+ " \"date\" : \"2015-08-23T00:01:45\",\n"
+ " \"action\" : \"start\",\n"
+ " \"myid\" : 2\n"
+ "}'\n"
+ "curl -XPUT 'http://localhost:9200/test8/test/4' -d '{\n"
+ " \"date\" : \"2015-08-23T00:01:55\",\n"
+ " \"action\" : \"start\",\n"
+ " \"myid\" : 3\n"
+ "}'\n"
+ "curl -XPUT 'http://localhost:9200/test8/test/5' -d '{\n"
+ " \"date\" : \"2015-08-23T14:04:00\",\n"
+ " \"action\" : \"stop\",\n"
+ " \"myid\" : 2\n"
+ "}'\n"
+ "curl -XPUT 'http://localhost:9200/test8/test/6' -d '{\n"
+ " \"date\" : \"2015-08-23T14:02:55\",\n"
+ " \"action\" : \"stop\",\n"
+ " \"myid\" : 3\n"
+ "}";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}