use strict;
my $str = 'curl -XPUT \'http://localhost:9200/test8/test/2\' -d \'{
"date" : "2015-08-23T14:02:30",
"action" : "stop",
"myid" : 1
}\'
curl -XPUT \'http://localhost:9200/test8/test/3\' -d \'{
"date" : "2015-08-23T00:01:45",
"action" : "start",
"myid" : 2
}\'
curl -XPUT \'http://localhost:9200/test8/test/4\' -d \'{
"date" : "2015-08-23T00:01:55",
"action" : "start",
"myid" : 3
}\'
curl -XPUT \'http://localhost:9200/test8/test/5\' -d \'{
"date" : "2015-08-23T14:04:00",
"action" : "stop",
"myid" : 2
}\'
curl -XPUT \'http://localhost:9200/test8/test/6\' -d \'{
"date" : "2015-08-23T14:02:55",
"action" : "stop",
"myid" : 3
}';
my $regex = qr/curl.+(\d).+\s*.+(\d{4}-\d{2}.+)\",\s*\".+\"\s*\:\s*\"([a-zA-z]*)\",/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}