const regex = /curl.+(\d).+\s*.+(\d{4}-\d{2}.+)\",\s*\".+\"\s*\:\s*\"([a-zA-z]*)\",/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('curl.+(\\d).+\\s*.+(\\d{4}-\\d{2}.+)\\",\\s*\\".+\\"\\s*\\:\\s*\\"([a-zA-z]*)\\",', 'gm')
const str = `curl -XPUT 'http://localhost:9200/test8/test/2' -d '{
"date" : "2015-08-23T14:02:30",
"action" : "stop",
"myid" : 1
}'
curl -XPUT 'http://localhost:9200/test8/test/3' -d '{
"date" : "2015-08-23T00:01:45",
"action" : "start",
"myid" : 2
}'
curl -XPUT 'http://localhost:9200/test8/test/4' -d '{
"date" : "2015-08-23T00:01:55",
"action" : "start",
"myid" : 3
}'
curl -XPUT 'http://localhost:9200/test8/test/5' -d '{
"date" : "2015-08-23T14:04:00",
"action" : "stop",
"myid" : 2
}'
curl -XPUT 'http://localhost:9200/test8/test/6' -d '{
"date" : "2015-08-23T14:02:55",
"action" : "stop",
"myid" : 3
}`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}