#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?im)^(?!#{1,6}\s|\*\s|\d+.\s|!|\[|>+\s+|-|\|)([^\n]*?)\n{1,}$"
Local $sString = "select this First in single line" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"select this second one line" & @CRLF & _
"" & @CRLF & _
"select these multiline paragraph" & @CRLF & _
"including this I want to select these 3 line in one paragraph" & @CRLF & _
"However only last line is selected in a group I am using [^\n]*?" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"# do not select anything below" & @CRLF & _
"> one line" & @CRLF & _
"" & @CRLF & _
"> multiline paragraph" & @CRLF & _
"> secondline" & @CRLF & _
"> single" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
">> one line" & @CRLF & _
"" & @CRLF & _
">> multiline paragraph" & @CRLF & _
">> secondline" & @CRLF & _
">> single" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"# heading" & @CRLF & _
"" & @CRLF & _
"---" & @CRLF & _
"" & @CRLF & _
"|S.No|name|" & @CRLF & _
"|:---|---|---|" & @CRLF & _
"|1|prateek|" & @CRLF & _
"" & @CRLF & _
"## headgin" & @CRLF & _
"" & @CRLF & _
"* list" & @CRLF & _
"" & @CRLF & _
"1. list" & @CRLF & _
"" & @CRLF & _
"11. asdfli" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"[asd](heading)" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")