use strict;
my $str = 'select this First in single line
select this second one line
select these multiline paragraph
including this I want to select these 3 line in one paragraph
However only last line is selected in a group I am using [^\\n]*?
# do not select anything below
> one line
> multiline paragraph
> secondline
> single
>> one line
>> multiline paragraph
>> secondline
>> single
# heading
---
|S.No|name|
|:---|---|---|
|1|prateek|
## headgin
* list
1. list
11. asdfli

[asd](heading)
';
my $regex = qr/^(?!#{1,6}\s|\*\s|\d+.\s|!|\[|>+\s+|-|\|)([^\n]*?)\n{1,}$/imp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}