const regex = /^(?!#{1,6}\s|\*\s|\d+.\s|!|\[|>+\s+|-|\|)([^\n]*?)\n{1,}$/igm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?!#{1,6}\\s|\\*\\s|\\d+.\\s|!|\\[|>+\\s+|-|\\|)([^\\n]*?)\\n{1,}$', 'igm')
const str = `select this First in single line
select this second one line
select these multiline paragraph
including this I want to select these 3 line in one paragraph
However only last line is selected in a group I am using [^\\n]*?
# do not select anything below
> one line
> multiline paragraph
> secondline
> single
>> one line
>> multiline paragraph
>> secondline
>> single
# heading
---
|S.No|name|
|:---|---|---|
|1|prateek|
## headgin
* list
1. list
11. asdfli

[asd](heading)
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}