$re = '/^(?!#{1,6}\s|\*\s|\d+.\s|!|\[|>+\s+|-|\|)([^\n]*?)\n{1,}$/im';
$str = 'select this First in single line
select this second one line
select these multiline paragraph
including this I want to select these 3 line in one paragraph
However only last line is selected in a group I am using [^\\n]*?
# do not select anything below
> one line
> multiline paragraph
> secondline
> single
>> one line
>> multiline paragraph
>> secondline
>> single
# heading
---
|S.No|name|
|:---|---|---|
|1|prateek|
## headgin
* list
1. list
11. asdfli

[asd](heading)
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);