import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?!#{1,6}\\s|\\*\\s|\\d+.\\s|!|\\[|>+\\s+|-|\\|)([^\\n]*?)\\n{1,}$";
final String string = "select this First in single line\n\n\n\n"
+ "select this second one line\n\n"
+ "select these multiline paragraph\n"
+ "including this I want to select these 3 line in one paragraph\n"
+ "However only last line is selected in a group I am using [^\\n]*?\n\n\n\n\n\n\n\n\n"
+ "# do not select anything below\n"
+ "> one line\n\n"
+ "> multiline paragraph\n"
+ "> secondline\n"
+ "> single\n\n\n\n"
+ ">> one line\n\n"
+ ">> multiline paragraph\n"
+ ">> secondline\n"
+ ">> single\n\n\n\n\n\n"
+ "# heading\n\n"
+ "---\n\n"
+ "|S.No|name|\n"
+ "|:---|---|---|\n"
+ "|1|prateek|\n\n"
+ "## headgin\n\n"
+ "* list\n\n"
+ "1. list\n\n"
+ "11. asdfli\n\n"
+ "\n\n"
+ "[asd](heading)\n\n\n\n\n\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}