#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\b(?!\s)([A-Z\sÀÈÌÒÙÁÉÍÓÚÝÂÊÎÔÛÃÑÕÄËÏÖÜŸ]{4,})\b[^A-ZÀÈÌÒÙÁÉÍÓÚÝÂÊÎÔÛÃÑÕÄËÏÖÜŸ]*CPF.*?(\d{3}.\d{3}.\d{3}.\d{2})"
Local $sString = "NOT THIS NAME, blah blah, ETC ETC ETC, XXXX 00.000.000/0001-00, blah blah, 123, ZIP 12345-123, blah blah, blah TEXT TEXT TEXT TEXT, blah blah THIS NAME, blah blah, blah blah CPF 999.999.999-99 blah blah"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")