import Foundation
let pattern = #"\b(?!\s)([A-Z\sÀÈÌÒÙÁÉÍÓÚÝÂÊÎÔÛÃÑÕÄËÏÖÜŸ]{4,})\b[^A-ZÀÈÌÒÙÁÉÍÓÚÝÂÊÎÔÛÃÑÕÄËÏÖÜŸ]*CPF.*?(\d{3}.\d{3}.\d{3}.\d{2})"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"NOT THIS NAME, blah blah, ETC ETC ETC, XXXX 00.000.000/0001-00, blah blah, 123, ZIP 12345-123, blah blah, blah TEXT TEXT TEXT TEXT, blah blah THIS NAME, blah blah, blah blah CPF 999.999.999-99 blah blah"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)