import re
regex = re.compile(r"\b(?!\s)([A-Z\sÀÈÌÒÙÁÉÍÓÚÝÂÊÎÔÛÃÑÕÄËÏÖÜŸ]{4,})\b[^A-ZÀÈÌÒÙÁÉÍÓÚÝÂÊÎÔÛÃÑÕÄËÏÖÜŸ]*CPF.*?(\d{3}.\d{3}.\d{3}.\d{2})", flags=re.MULTILINE)
test_str = "NOT THIS NAME, blah blah, ETC ETC ETC, XXXX 00.000.000/0001-00, blah blah, 123, ZIP 12345-123, blah blah, blah TEXT TEXT TEXT TEXT, blah blah THIS NAME, blah blah, blah blah CPF 999.999.999-99 blah blah"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")