#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(^[^\/]*?\/)(?:.*)"
Local $sString = "domain.com/#/test " & @CRLF & _
"domain.com/#/"
Local $sSubst = "\1#/view-0"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)