const regex = /(^[^\/]*?\/)(?:.*)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(^[^\\\/]*?\\\/)(?:.*)', 'gm')
const str = `domain.com/#/test
domain.com/#/`;
const subst = `\1#/view-0`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);