package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(^[^\/]*?\/)(?:.*)`)
var str = `domain.com/#/test
domain.com/#/`
var substitution = "\1#/view-0"
fmt.Println(re.ReplaceAllString(str, substitution))
}