$re = '/(^[^\/]*?\/)(?:.*)/m';
$str = 'domain.com/#/test
domain.com/#/';
$subst = "\1#/view-0";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;