re = /(^[^\/]*?\/)(?:.*)/m
str = 'domain.com/#/test
domain.com/#/'
subst = '\\1#/view-0'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result