#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(\d+(?:$|(?:-\d+)+))"
Local $sString = "#Match" & @CRLF & _
"1" & @CRLF & _
"34-1" & @CRLF & _
"2-5-2" & @CRLF & _
"15-2-3-309-1" & @CRLF & _
"" & @CRLF & _
"# Don't match" & @CRLF & _
"1--" & @CRLF & _
"--" & @CRLF & _
"#$@%^#$@#" & @CRLF & _
"dafadf" & @CRLF & _
"10-asdf-1" & @CRLF & _
"-12-1-" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")