import re
regex = re.compile(r"^(\d+(?:$|(?:-\d+)+))", flags=re.MULTILINE)
test_str = ("#Match\n"
"1\n"
"34-1\n"
"2-5-2\n"
"15-2-3-309-1\n\n"
"# Don't match\n"
"1--\n"
"--\n"
"#$@%^#$@#\n"
"dafadf\n"
"10-asdf-1\n"
"-12-1-\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")