re = /^(\d+(?:$|(?:-\d+)+))/m
str = '#Match
1
34-1
2-5-2
15-2-3-309-1
# Don\'t match
1--
--
#$@%^#$@#
dafadf
10-asdf-1
-12-1-
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end