import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(\\d+(?:$|(?:-\\d+)+))";
final String string = "#Match\n"
+ "1\n"
+ "34-1\n"
+ "2-5-2\n"
+ "15-2-3-309-1\n\n"
+ "# Don't match\n"
+ "1--\n"
+ "--\n"
+ "#$@%^#$@#\n"
+ "dafadf\n"
+ "10-asdf-1\n"
+ "-12-1-\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}