const regex = new RegExp('^(\\d+(?:$|(?:-\\d+)+))', 'mg')
const str = `#Match
1
34-1
2-5-2
15-2-3-309-1
# Don't match
1--
--
#\$@%^#\$@#
dafadf
10-asdf-1
-12-1-
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}