#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<!\\)"[^"\\]*(?:\\.[^"\\]*)*""
Local $sString = ""first | last | name" |" john | white "| age | 52" & @CRLF & _
"school |" ABC | USA "| year | 2016" & @CRLF & _
"Home | Road | year\" | 1989\" " & @CRLF & _
"company |" Pvt | ltd "| joining | 2019" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")