re = /(?<!\\)"[^"\\]*(?:\\.[^"\\]*)*"/m
str = '"first | last | name" |" john | white "| age | 52
school |" ABC | USA "| year | 2016
Home | Road | year\\" | 1989\\"
company |" Pvt | ltd "| joining | 2019
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end