$re = '/(?<!\\\\)"[^"\\\\]*(?:\\\\.[^"\\\\]*)*"/m';
$str = '"first | last | name" |" john | white "| age | 52
school |" ABC | USA "| year | 2016
Home | Road | year\\" | 1989\\"
company |" Pvt | ltd "| joining | 2019
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);