using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<!\\)""[^""\\]*(?:\\.[^""\\]*)*""";
string input = @"""first | last | name"" |"" john | white ""| age | 52
school |"" ABC | USA ""| year | 2016
Home | Road | year\"" | 1989\""
company |"" Pvt | ltd ""| joining | 2019
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}