using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\bMyHost=""xxxx""\r?\n.*?MyIp=\s*\""([^""]*)";
string input = @"blah blah blah MyHost=""xxxx""
again blah blah blah MyIp= ""x.x.x.x""";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}