$re = '/\bMyHost="xxxx"\r?\n.*?MyIp=\s*\"([^"]*)/i';
$str = 'blah blah blah MyHost="xxxx"
again blah blah blah MyIp= "x.x.x.x"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);