import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\bMyHost=\"xxxx\"\\r?\\n.*?MyIp=\\s*\\\"([^\"]*)";
final String string = "blah blah blah MyHost=\"xxxx\"\n"
+ "again blah blah blah MyIp= \"x.x.x.x\"";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}